PCCar.ru - Ваш автомобильный компьютер

Вернуться   PCCar.ru - Ваш автомобильный компьютер > MP3Car ТехИнфа > Видеорегистрация

Ответ
 
Опции темы
Старый 28.11.2011, 19:13   #1
kazanova
Старший Пользователь
 
Регистрация: 05.03.2008
Возраст: 34
Город: Тверь
Регион: 69
Машина: Mitsubishi Pajero, 1996
Сообщений: 129
kazanova is on a distinguished road
По умолчанию Intel d945: видеопоток рубит звук

Всем привет!

Решил написать сюда, поскольку проблема обнаружилась именно при установке и тестировании системы видеорегистрации.

Конфигурация компа: Intel D945GCLF2D с атомом 330, 2Gb RAM, Windows 7! Дрова стоят последние, взятые с сайта интела. Со звуком никаких проблем не было, пока не подключил веб-камеру logitech c310. Когда поставил камеру и попытался посмотреть в нее, звук начал тормозить, хрипеть, пердеть. И чем жирнее поток (выше разрешение и fps), тем звук сильнее заваливается вплоть до такого, что вообще не разобрать, что играет.

Поначалу я подумал, что проц упирается в потолок. Нет, использование проца при тормозах 25-40% (50-70% на одном ядре, и 3-10% на втором). Камера подключена через удлинитель в порт на матери, без хабов. Попробовал воткнуть в другой порт (их там 4, они все рядом). Странно, но на другом порту звук стал заикаться гораздо меньше, при потоке 960х720@10fps треска почти не наблюдается, но все же иногда проскакивает. Включаю дополнительно GPS - опять треск (GPS висел на хабе, зачем ему отдельный порт с его 4800baud?). Переставил GPS в отдельный порт на матери - треска стало меньше, но он есть

Подскажите, отчего это? Южный мост (или как там его) не справляется? А может дело в драйверах или Win7? Пробовал разные проигрыватели, запускал их с высоким приоритетом - все одинаково, проблема на уровне дров/железа.
kazanova вне форума   Ответить с цитированием
Старый 28.11.2011, 20:34   #2
Stasik
Старший Пользователь
 
Аватар для Stasik
 
Регистрация: 03.12.2007
Возраст: 38
Город: Москва, м.Севастопольская
Регион: 77, 97, 99, 177
Машина: MAZDA 6 2008 Sport
Сообщений: 938
Stasik is a name known to allStasik is a name known to allStasik is a name known to allStasik is a name known to allStasik is a name known to allStasik is a name known to all
По умолчанию

Цитата:
Сообщение от kazanova Посмотреть сообщение
Всем привет!

Решил написать сюда, поскольку проблема обнаружилась именно при установке и тестировании системы видеорегистрации.

Конфигурация компа: Intel D945GCLF2D с атомом 330, 2Gb RAM, Windows 7! Дрова стоят последние, взятые с сайта интела. Со звуком никаких проблем не было, пока не подключил веб-камеру logitech c310. Когда поставил камеру и попытался посмотреть в нее, звук начал тормозить, хрипеть, пердеть. И чем жирнее поток (выше разрешение и fps), тем звук сильнее заваливается вплоть до такого, что вообще не разобрать, что играет.

Поначалу я подумал, что проц упирается в потолок. Нет, использование проца при тормозах 25-40% (50-70% на одном ядре, и 3-10% на втором). Камера подключена через удлинитель в порт на матери, без хабов. Попробовал воткнуть в другой порт (их там 4, они все рядом). Странно, но на другом порту звук стал заикаться гораздо меньше, при потоке 960х720@10fps треска почти не наблюдается, но все же иногда проскакивает. Включаю дополнительно GPS - опять треск (GPS висел на хабе, зачем ему отдельный порт с его 4800baud?). Переставил GPS в отдельный порт на матери - треска стало меньше, но он есть

Подскажите, отчего это? Южный мост (или как там его) не справляется? А может дело в драйверах или Win7? Пробовал разные проигрыватели, запускал их с высоким приоритетом - все одинаково, проблема на уровне дров/железа.
Значит ситуация еще вот в чем.
На ноутбуке я включал торрент закачку, ноут в интернет выходит по Wifi.
Во время закачки хотел посмотреть фильм, звук аналогично начал пердеть, думал кодек глючит, переустановил непомогло. Потом обнаружил что WiFi во время работы дает наводки на звуковой тракт или на то что до него.

Соответственно, еслибы проц не справлялся, то звук бы не пердел, а просто заикался, что иногда бывает при большой нагрузке на проц.

А у Вас соответственно
Цитата:
что вообще не разобрать, что играет
, но он все-таки играет, хоть и пердит так что не разобрать, верно?, значит думаю копать надо на наводки.
__________________
Разработка корпусов для Pccar Мой проект Mazda 6 New

Tel: +7(903)105-4988 ICQ: 198359855 Email: fixup@bk.ru
Stasik вне форума   Ответить с цитированием
Старый 29.11.2011, 01:38   #3
kazanova
Старший Пользователь
 
Регистрация: 05.03.2008
Возраст: 34
Город: Тверь
Регион: 69
Машина: Mitsubishi Pajero, 1996
Сообщений: 129
kazanova is on a distinguished road
По умолчанию

Stasik, нет, звук именно заикается и тормозит. Т.е. секундный кусок песни может тянуться секунды 3-4 (на больших fps) причем с характерным звуком как у робота (кто играл в "систем шок 2" тот точно поймет о чем я ). В звуковом потоке появляются короткие частые провалы, создающие такую киборг-модуляцию

А еще после всех этих экспериментов, системные звуки стали шипеть при проигрывании. Когда все тихо, ничего не слышно. Когда система проигрывает звук какого-то события, на фоне этого звука раздается шипение.
kazanova вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Часовой пояс GMT +4, время: 11:37.


Работает на vBulletin® версия 3.8.4.
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Перевод: zCarot
Яндекс.Метрика